Questo sito utilizza cookie per migliorare la tua esperienza e offrire servizi in linea con le tue preferenze. Chiudendo questo banner, scorrendo questa pagina o cliccando qualunque suo elemento potresti acconsentire all’uso dei cookie. Se vuoi saperne di più o negare il consenso a tutti o ad alcuni cookie approfondisci

Rilasciata una versione non ufficiale della 1.5

La Joomla 1.5 non è più supportata da tempo, ma sono ancora moltissimi i siti web che per diverse ragioni non sono migrati alla 2.5. Molti webmaster hanno buoni motivi per non migrare, tra cui il più ovvio è quello di non poter trasportare quanto costruito nella vecchia release stabile del cms.

Molti componenti tra cui gallerie fotografiche, cataloghi, ecommerce, ma anche moduli e plugin vari (indipensabili per qualche creatura ideata qualche anno fa) non hanno proposto la versione per la Joomla 2.5 e si sono arenati alla vecchia 1.5.


Per questo, molti webmaster non possono migrare i siti dei clienti o quelli personali, e a loro non resta che cercare di limitare le vulnerabilità.

Joomla.it viene incontro a webmaster o semplici appassionati che hanno montato la Joomla 1.5 rilasciando un aggiornamento che si propone di "limitare i danni" riducendo al minimo le vulnerabilità già note.

Da diversi mesi, oltre al famoso JCE che non ha fatto dormire molti "costruttori" di siti web che si sono visti defacciare il loro sito tramite questo componente, la J 1.5.26 non è sicura. In generale, bisogna tener presente che altri componenti possono avere vulnerabilità che col tempo diverranno punti deboli rilevanti per un sito non aggiornato alla 2.5.

Un'altra vulnerabilità nota, che purtroppo verrà sempre più sfruttata nei mesi a venire, riguarda il template Ja_purity. Per compensare a questo problemone il team di Joomla.it ha pensato di rilasciare un aggiornamento non ufficiale localizzato in italiano.

 

La nuova release si chiamerà Joomla 1.5.26b e potete scaricarla da qui

 

Ricordando che, nonostante questo rilascio autonomo, la Joomla 1.5 non è più supportata dal team ufficiale, l'unica soluzione intelligente ed utile allo scopo di ridurre il rischio hacheraggio è quella di abbandonare definitivamente la 1.5 e passare alla 2.5.

 

Se ciò non è possibile per i motivi elencati prima, è bene disinstallare il template jpurity oppure cancellare via FTP la cartella /templates/ja_purity.

Ovviamente, parliamo di vulnerabilità note, ma statene certi, nelle prossime settimane altri problemi di sicurezza colpiranno il cms, componenti, moduli e plugin arenati alla 1.5.

 

Concludendo, inutile girarci attorno, possiamo tappare falle e vulnerabilità, ma la soluzione è solo una: migrare, migrare, migrare! Più sotto troverai qualche utile link che tratta della migrazione alla 2.5. Spero possano essere utili.

Letto 2728 volte

Ultimi Articoli

You are here:   Joomla Blog HomeNewsLe News di JoomlaRilasciata una versione non ufficiale della 1.5